HOL LogoGuard

Explore HOL

  • HOL home
  • AI agent registry
  • AI plugins
  • Open standards
  • HOL members
  • Sponsor HOL
  • Advertise with HOL

Guard product

  • Guard overviewLocal security and control for AI agents and the tools they use.
  • FeaturesRuntime protection, policy routing, review, and evidence.

Explore Guard

  • Product previewWalk through Guard surfaces in read-only demo mode.
  • ComparisonCompare Guard with native controls and AI security vendors.

AI tools

  • All AI toolsEvery supported AI tool and how Guard applies policy to it.
  • Codex
  • Claude Code
  • Cursor
  • Antigravity CLI
  • OpenCode
  • Hermes
  • OpenClaw
  • GitHub Copilot CLI
  • Antigravity
  • Kimi
  • Grok
  • Pi / Oh My Pi
  • Zcode

Extensions

  • All extensionsBrowse command and MCP coverage with owners and stated limits.
  • Command coverageShell command protection across clouds, databases, backups, and packages.
  • MCP server coverageSee how Guard maps risk state across MCP tools and servers.
  • Core safetyThe safety floor listings that ship with Guard.
  • Data and resilienceBackup and storage command protection.
  • Cloud and infrastructureAWS, Azure, GCP, Kubernetes, and more.

Security

  • AI security hubSecurity research, advisories, and agent safety coverage.
  • AI tool securitySecurity profiles for each supported coding agent.
  • Safe labsHands-on attack simulations with safe boundaries.
  • Redacted warningsReal blocked actions with sensitive details removed.
  • AdvisoriesCoordinated disclosure reports for AI tooling.
  • Active CVEsSearch active CVEs affecting AI tooling.

Learn

  • Security guidesPractical guides for securing AI agent workflows.
  • DocsInstall, configure, and operate Guard with confidence.
  • ResearchPublished security research, benchmarks, and methodology.

Community

  • ReleasesVersion history, shipped changes and upgrade notes.
  • ContributorsThe people and contributions behind HOL Guard.
  • AffiliatesShare Guard with your audience and earn from referrals.
  • SponsorFund agreed research, implementation and shared testing through the HOL Partner Program.
  • AdvertiseCompare README logo placements, previews and monthly prices, or promote a plugin or extension.
PricingEnterpriseOpen AppInstall Guard
  1. Guard
  2. Security
  3. CVEs
  4. CVE 2022 24112 apisixbatch requests plugin allows overwriting
HOL Guard

Public security guidance for teams protecting AI harnesses, MCP servers, skills, prompts, and local tool execution.

Install Guard

AI Security

  • Prompt injection
  • MCP security
  • OWASP MCP mapping
  • Supply chain

Resources

  • Trust packet
  • Harness setup
  • Redacted warnings
  • Safe labs

Product

  • Install Guard
  • Pricing
  • Open dashboard
Guard
  • Guard Overview
  • Releases
  • Contributors
  • Install Guard
  • Pricing
Docs
  • Documentation Index
  • Developer Hub
  • API Reference
  • Root OpenAPI
  • Registry OpenAPI
  • Run in Postman
  • Standards
  • Submit ERC-8004 Contract
  • Feature Your Agent
Best Plugins
  • Browse Plugins
  • Plugin Launches
  • Best Claude Plugins
  • Best Codex Plugins
  • Best Grok Plugins
  • Best Kimi Plugins
  • Best DeepSeek Plugins
  • Best Antigravity Plugins
  • Best MCP Servers
  • Best Cursor Plugins
  • Best OpenCode Plugins
Best Agents
  • Best ERC-8004 Agents
  • Best Virtuals Agents
  • Best MCP Servers
  • Best A2A Agents
  • Best x402 Payable
  • All Categories
Community
  • Contribute to HOL
  • Telegram
  • X
More
  • About HOL
  • Sponsor
  • Advertise
  • Affiliate program
  • Contact
  • Blog
  • GitHub
  • Privacy
  • Terms of Service
Settings

Copyright © 2026 HOL DAO LLC. All rights reserved.

Back to active CVEs
Critical · CVSS 9.8Known ExploitedCVE-2022-24112

apisix/batch-requests plugin allows overwriting the X-REAL-IP headerCVE-2022-24112

Answer in brief

CVE-2022-24112 records a Critical severity (CVSS 9.8) vulnerability in apisix/batch-requests plugin allows overwriting the X-REAL-IP header. The current sources mark it as known exploited. The current feed maps Apache Software Foundation/Apache APISIX (generic). Check affected ranges and fixed versions before updating.

Analysis pending evidence review

HOL Guard separates source facts from reviewed analysis. See the methodology.

Published Feb 11, 2022Updated Oct 21, 2025Source checked Nov 4, 2026First seen by HOL May 24, 2026Material review Oct 21, 2025
Upstream Advisory

Key facts

Risk
Critical · CVSS 9.8
Exploitation
Known exploited
Affected software
1 mapped package or product
Fix availability
Available

Why this deserves its current priority

CVSS is 9.8. Known-exploitation status makes exposure review time-sensitive. Treat this as a source-backed prioritization signal, not a statement about your environment.

Analysis status

Analysis pending evidence review

Factual feed record only; HOL analysis is not approved for indexing. Read the methodology.

Affected scope and exposure questions

The current feed maps Apache Software Foundation/Apache APISIX (generic). Check affected ranges and fixed versions before updating.

Mapped affected packages and fixed versions
PackageAffected rangeFixed version
Apache Software Foundation/Apache APISIXgeneric>=Apache APISIX 2.12 <2.12.1 || >=Apache APISIX 2.10 <2.10.4 || >=1.3 <Apache APISIX 1*2.12.1, 2.10.4, Apache APISIX 1*

Recommended response

  1. 1Check inventory. Check lockfiles and deployed manifests for Apache Software Foundation/Apache APISIX.
  2. 2Review the reported fix. Source-reported workaround: 1. explicitly configure the enabled plugins in `conf/config.yaml`, ensure `batch-requests` is disabled. (Or just comment out `batch-requests` in `conf/config-default.yaml`) Or 1. upgrade to 2.10.4 or 2.12.1.

Evidence timeline and material changes

  1. Published upstream

    Feb 11, 2022

    Evidence: source:cvelist:source_dates:source-dates:record
  2. Source modified

    Oct 21, 2025

    Evidence: source:cvelist:source_dates:source-dates:record
  3. First seen by HOL

    May 24, 2026

  4. Added to CISA KEV

    Aug 25, 2022

    Evidence: source:kev:kev:kev:record

Sources and claim methodology

  • Source referencepacketstormsecurity.com
  • Source referencepacketstormsecurity.com
  • Source referencelists.apache.org
  • CISA Known Exploited Vulnerabilities catalogcisa.gov
  • Source referenceopenwall.com
Upstream source description

An attacker can abuse the batch-requests plugin to send requests to bypass the IP restriction of Admin API. A default configuration of Apache APISIX (with default API key) is vulnerable to remote code execution. When the admin key was changed or the port of Admin API was changed to a port different from the data panel, the impact is lower. But there is still a risk to bypass the IP restriction of Apache APISIX's data panel. There is a check in the batch-requests plugin which overrides the client IP with its real remote IP. But due to a bug in the code, this check can be bypassed.

Quoted source text, attributed separately from HOL analysis.

Related CVEs

  • Symfony: X.509 Authentication Impersonation via DN Value Injection (incomplete fix for CVE-2026-45063)Also CWE-290
  • Databasement before 1.10.9 Account Takeover via OIDC Email Auto-LinkingAlso CWE-290

Record context

Vulnerability class
RCE
EPSS
Not reported
CWE IDs
CWE-290
Source
CVE List V5
Source checked
Nov 4, 2026
References
5 linked sources
Open source record