Answer in brief
CVE-2024-31449 records a High severity (CVSS 7.0) vulnerability in Lua library commands may lead to stack overflow and RCE in Redis. The current sources do not mark it as known exploited. The current feed maps redis/redis (generic). Check affected ranges and fixed versions before updating.
Analysis pending evidence review
HOL Guard separates source facts from reviewed analysis. See the methodology.
CVSS is 7.0. The current sources do not mark it as known exploited. Treat this as a source-backed prioritization signal, not a statement about your environment.
Analysis status
Analysis pending evidence review
Factual feed record only; HOL analysis is not approved for indexing. Read the methodology.
The current feed maps redis/redis (generic). Check affected ranges and fixed versions before updating.
| Package | Affected range | Fixed version |
|---|---|---|
| redis/redisgeneric | >=2.6 <6.2.16 || >=7.0.0 <7.2.6 || >=7.3.0 <7.4.1 | 6.2.16, 7.2.6, 7.4.1 |
Published upstream
Oct 7, 2024
Evidence: source:cvelist:source_dates:source-dates:recordSource modified
Nov 3, 2026
Evidence: source:cvelist:source_dates:source-dates:recordFirst seen by HOL
Nov 3, 2026
Redis is an open source, in-memory database that persists on disk. An authenticated user may use a specially crafted Lua script to trigger a stack buffer overflow in the bit library, which may potentially lead to remote code execution. The problem exists in all versions of Redis with Lua scripting. This problem has been fixed in Redis versions 6.2.16, 7.2.6, and 7.4.1. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Quoted source text, attributed separately from HOL analysis.