Answer in brief
CVE-2024-42360 records a Critical severity (CVSS 9.8) vulnerability in Command Injection in sequenceserver. The current sources do not mark it as known exploited. The current feed maps wurmlab/sequenceserver (generic), sequenceserver (rubygems). Check affected ranges and fixed versions before updating.
Analysis pending evidence review
HOL Guard separates source facts from reviewed analysis. See the methodology.
CVSS is 9.8. The current sources do not mark it as known exploited. Treat this as a source-backed prioritization signal, not a statement about your environment.
Analysis status
Analysis pending evidence review
Factual feed record only; HOL analysis is not approved for indexing. Read the methodology.
The current feed maps wurmlab/sequenceserver (generic), sequenceserver (rubygems). Check affected ranges and fixed versions before updating.
| Product | Affected versions | Fixed versions |
|---|---|---|
| cpe:2.3:a:wurmlab:sequenceserver:*:*:*:*:*:ruby:*:* | Not reported | Not reported |
| Package | Affected range | Fixed version |
|---|---|---|
| wurmlab/sequenceservergeneric | <3.1.2 | 3.1.2 |
| sequenceserverrubygems | >=0 <3.1.2 | 3.1.2 |
Published upstream
Aug 14, 2024
Evidence: source:cvelist:source_dates:source-dates:recordSource modified
Oct 29, 2026
Evidence: source:cvelist:source_dates:source-dates:recordFirst seen by HOL
Aug 7, 2026
SequenceServer lets you rapidly set up a BLAST+ server with an intuitive user interface for personal or group use. Several HTTP endpoints did not properly sanitize user input and/or query parameters. This could be exploited to inject and run unwanted shell commands. This vulnerability has been fixed in 3.1.2.
Quoted source text, attributed separately from HOL analysis.