Answer in brief
CVE-2024-45409 records a Critical severity (CVSS 10.0) vulnerability in The Ruby SAML library vulnerable to a SAML authentication bypass via Incorrect XPath selector. The current sources do not mark it as known exploited. The current feed maps omniauth/omniauth-saml (generic), SAML-Toolkits/ruby-saml (generic), onelogin/ruby-saml (generic), ruby-saml (rubygems) and additional mapped packages. Check affected ranges and fixed versions before updating.
Analysis pending evidence review
HOL Guard separates source facts from reviewed analysis. See the methodology.
CVSS is 10.0. The current sources do not mark it as known exploited. Treat this as a source-backed prioritization signal, not a statement about your environment.
Analysis status
Analysis pending evidence review
Factual feed record only; HOL analysis is not approved for indexing. Read the methodology.
The current feed maps omniauth/omniauth-saml (generic), SAML-Toolkits/ruby-saml (generic), onelogin/ruby-saml (generic), ruby-saml (rubygems) and additional mapped packages. Check affected ranges and fixed versions before updating.
| Package | Affected range | Fixed version |
|---|---|---|
| omniauth/omniauth-samlgeneric | >=0 <=2.1.0 | Not reported |
| SAML-Toolkits/ruby-samlgeneric | <1.12.3 || >=1.13.0 <1.17.0 | 1.12.3, 1.17.0 |
| onelogin/ruby-samlgeneric | >=0 <1.12.3 || >=1.13.0 <1.17.0 | 1.12.3, 1.17.0 |
| ruby-samlrubygems | >=0 <1.12.3 | 1.12.3 |
| ruby-samlrubygems | >=1.13.0 <1.17.0 | 1.17.0 |
Published upstream
Sep 10, 2024
Evidence: source:cvelist:source_dates:source-dates:recordSource modified
Nov 3, 2026
Evidence: source:cvelist:source_dates:source-dates:recordFirst seen by HOL
Aug 8, 2026
The Ruby SAML library is for implementing the client side of a SAML authorization. Ruby-SAML in <= 12.2 and 1.13.0 <= 1.16.0 does not properly verify the signature of the SAML Response. An unauthenticated attacker with access to any signed saml document (by the IdP) can thus forge a SAML Response/Assertion with arbitrary contents. This would allow the attacker to log in as arbitrary user within the vulnerable system. This vulnerability is fixed in 1.17.0 and 1.12.3.
Quoted source text, attributed separately from HOL analysis.