Answer in brief
CVE-2025-2000 records a Critical severity (CVSS 9.8) vulnerability in Qiskit allows arbitrary code execution decoding QPY format versions < 13. The current sources do not mark it as known exploited. The current feed maps qiskit (pip), qiskit (pip), qiskit-terra (pip). Check affected ranges and fixed versions before updating.
Analysis pending evidence review
HOL Guard separates source facts from reviewed analysis. See the methodology.
CVSS is 9.8. The current sources do not mark it as known exploited. Treat this as a source-backed prioritization signal, not a statement about your environment.
Analysis status
Analysis pending evidence review
Factual feed record only; HOL analysis is not approved for indexing. Read the methodology.
The current feed maps qiskit (pip), qiskit (pip), qiskit-terra (pip). Check affected ranges and fixed versions before updating.
| Package | Affected range | Fixed version |
|---|---|---|
| qiskitpip | <=1.4.1 | 1.4.2 |
| qiskitpip | =2.0.0rc1 | 2.0.0rc2 |
| qiskit-terrapip | >=0.18.0,<=0.46.3 | Not reported |
Published upstream
Mar 14, 2025
Evidence: source:ghsa:source_dates:source-dates:recordSource modified
Nov 4, 2026
Evidence: source:ghsa:source_dates:source-dates:recordFirst seen by HOL
Nov 4, 2026
### Impact A maliciously crafted QPY file can potentially execute arbitrary-code embedded in the payload without privilege escalation when deserializing QPY formats < 13. A python process calling Qiskit's `qiskit.qpy.load()` function could potentially execute any arbitrary Python code embedded in the correct place in the binary file as part of a specially constructed payload. ### Patches Fixed in Qiskit 1.4.2 and in Qiskit 2.0.0rc2
Quoted source text, attributed separately from HOL analysis.