Answer in brief
CVE-2025-64408 records a Medium severity (CVSS 6.3) vulnerability in Apache Causeway: Java deserialization vulnerability to authenticated attackers. The current sources do not mark it as known exploited. The current feed maps Apache Software Foundation/org.apache.causeway:* (generic). Check affected ranges and fixed versions before updating.
Analysis pending evidence review
HOL Guard separates source facts from reviewed analysis. See the methodology.
CVSS is 6.3. The current sources do not mark it as known exploited. Treat this as a source-backed prioritization signal, not a statement about your environment.
Analysis status
Analysis pending evidence review
Factual feed record only; HOL analysis is not approved for indexing. Read the methodology.
The current feed maps Apache Software Foundation/org.apache.causeway:* (generic). Check affected ranges and fixed versions before updating.
| Product | Affected versions | Fixed versions |
|---|---|---|
| cpe:2.3:a:apache:causeway:*:*:*:*:*:*:*:* | Not reported | Not reported |
| cpe:2.3:a:apache:causeway:4.0.0:m1:*:*:*:*:*:* | Not reported | Not reported |
| Package | Affected range | Fixed version |
|---|---|---|
| Apache Software Foundation/org.apache.causeway:*generic | >=2.0.0 <=3.4.0 || 4.0.0-M1 | Not reported |
Published upstream
Nov 19, 2025
Evidence: source:cvelist:source_dates:source-dates:recordSource modified
Nov 3, 2026
Evidence: source:cvelist:source_dates:source-dates:recordFirst seen by HOL
Oct 28, 2026
Apache Causeway faces Java deserialization vulnerabilities that allow remote code execution (RCE) through user-controllable URL parameters. These vulnerabilities affect all applications using Causeway's ViewModel functionality and can be exploited by authenticated attackers to execute arbitrary code with application privileges. This issue affects all current versions. Users are recommended to upgrade to version 3.5.0, which fixes the issue.
Quoted source text, attributed separately from HOL analysis.