Answer in brief
CVE-2026-10148 records a Medium severity (CVSS 6.4) vulnerability in Booking for Appointments and Events Calendar – Amelia <= 2.4.9 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'load_manually' Parameter. The current sources do not mark it as known exploited. The current feed maps melograno/Booking for Appointments and Events Calendar – Amelia (generic), melograno/Booking for Appointments and Events Calendar – Amelia (generic). Check affected ranges and fixed versions before updating.
Analysis pending evidence review
HOL Guard separates source facts from reviewed analysis. See the methodology.
CVSS is 6.4. The current sources do not mark it as known exploited. Treat this as a source-backed prioritization signal, not a statement about your environment.
Analysis status
Analysis pending evidence review
Factual feed record only; HOL analysis is not approved for indexing. Read the methodology.
The current feed maps melograno/Booking for Appointments and Events Calendar – Amelia (generic), melograno/Booking for Appointments and Events Calendar – Amelia (generic). Check affected ranges and fixed versions before updating.
| Package | Affected range | Fixed version |
|---|---|---|
| melograno/Booking for Appointments and Events Calendar – Ameliageneric | >=0 <=2.4.9 | Not reported |
| melograno/Booking for Appointments and Events Calendar – Ameliageneric | 0 | Not reported |
Published upstream
Sep 12, 2026
Evidence: source:cvelist:source_dates:source-dates:recordSource modified
Sep 14, 2026
Evidence: source:cvelist:source_dates:source-dates:recordFirst seen by HOL
Sep 12, 2026
The Booking for Appointments and Events Calendar plugin for WordPress is vulnerable to Stored Cross-Site Scripting via multiple Elementor widgets in versions up to and including 2.4.9. This is due to insufficient input sanitization and output escaping on the 'load_manually' parameter in the render() methods of classes. This makes it possible for authenticated attackers, with Contributor-level access and above who can use Elementor, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 2.4.8.
Quoted source text, attributed separately from HOL analysis.