Answer in brief
CVE-2026-118772 records a High severity (CVSS 7.5) vulnerability in joi: quadratic-time split in `string().email({ multiple: true })` allows denial of service. The current sources do not mark it as known exploited. The current feed maps hapijs/joi (generic), @hapi/joi (generic). Check affected ranges and fixed versions before updating.
Analysis pending evidence review
HOL Guard separates source facts from reviewed analysis. See the methodology.
CVSS is 7.5. The current sources do not mark it as known exploited. Treat this as a source-backed prioritization signal, not a statement about your environment.
Analysis status
Analysis pending evidence review
Factual feed record only; HOL analysis is not approved for indexing. Read the methodology.
The current feed maps hapijs/joi (generic), @hapi/joi (generic). Check affected ranges and fixed versions before updating.
| Package | Affected range | Fixed version |
|---|---|---|
| hapijs/joigeneric | >=16.0.0 <=17.1.1 || >=18.0.0 <18.3.1 | 18.3.1 |
| @hapi/joigeneric | >=16.0.0 <=17.1.1 | Not reported |
Published upstream
Oct 29, 2026
Evidence: source:cvelist:source_dates:source-dates:recordSource modified
Oct 29, 2026
Evidence: source:cvelist:source_dates:source-dates:recordFirst seen by HOL
Oct 29, 2026
joi is a schema description language and data validator for JavaScript. From 17.1.1 until 17.13.9 and 18.3.1, the Joi.string().email({ multiple: true }) rule uses a separator regular expression whose leading whitespace quantifier is retried at every position in a long whitespace run that contains no separator, causing quadratic work during String.prototype.split. The behavior applies to the default separator and every custom separator. Applications that validate attacker-controlled values with the multiple option and no effective prior length limit can have the Node.js event loop blocked for seconds by one request, preventing other work. A .max() rule is not sufficient when abortEarly: false allows the email rule to run after the maximum-length check fails. This vulnerability is fixed in versions 17.13.9 and 18.3.1.
Quoted source text, attributed separately from HOL analysis.