Answer in brief
CVE-2026-25632 records a Critical severity (CVSS 10.0) vulnerability in EPyT-Flow vulnerable to unsafe JSON deserialization (__type__). The current sources do not mark it as known exploited. The current feed maps epyt-flow (pip), epyt-flow (pypi). Check affected ranges and fixed versions before updating.
Analysis pending evidence review
HOL Guard separates source facts from reviewed analysis. See the methodology.
CVSS is 10.0. The current sources do not mark it as known exploited. Treat this as a source-backed prioritization signal, not a statement about your environment.
Analysis status
Analysis pending evidence review
Factual feed record only; HOL analysis is not approved for indexing. Read the methodology.
The current feed maps epyt-flow (pip), epyt-flow (pypi). Check affected ranges and fixed versions before updating.
| Package | Affected range | Fixed version |
|---|---|---|
| epyt-flowpip | <0.16.1 | 0.16.1 |
| epyt-flowpypi | >=0 <0.16.1 | 0.16.1 |
Published upstream
Feb 4, 2026
Evidence: source:ghsa:source_dates:source-dates:recordSource modified
Oct 27, 2026
Evidence: source:ghsa:source_dates:source-dates:recordFirst seen by HOL
Oct 27, 2026
### Impact EPyT-Flow’s REST API parses attacker-controlled JSON request bodies using a custom deserializer (my_load_from_json) that supports a __type__ field. When __type__ is present, the deserializer dynamically imports an attacker-specified module/class and instantiates it with attacker-supplied arguments. This allows invoking dangerous classes such as subprocess.Popen, which can lead to OS command execution during JSON parsing. This also affects the loading of JSON files. ### Patches EPyT-Flow has been patched in 0.16.1 -- affects all versions <= 0.16.0 ### Workarounds Do not load any JSON from untrusted sources and do not expose the REST API. ### Credits EPyT-Flow thanks Jarrett Chan (@syphonetic) for detecting and reporting the bug.
Quoted source text, attributed separately from HOL analysis.