Answer in brief
CVE-2026-30912 records a High severity (CVSS 7.5) vulnerability in Apache Airflow: Exposing stack trace in case of constraint error. The current sources do not mark it as known exploited. The current feed maps Apache Software Foundation/apache-airflow (generic), Apache Software Foundation/apache-airflow-core (generic), apache-airflow-core (pip). Check affected ranges and fixed versions before updating.
Analysis pending evidence review
HOL Guard separates source facts from reviewed analysis. See the methodology.
CVSS is 7.5. The current sources do not mark it as known exploited. Treat this as a source-backed prioritization signal, not a statement about your environment.
Analysis status
Analysis pending evidence review
Factual feed record only; HOL analysis is not approved for indexing. Read the methodology.
The current feed maps Apache Software Foundation/apache-airflow (generic), Apache Software Foundation/apache-airflow-core (generic), apache-airflow-core (pip). Check affected ranges and fixed versions before updating.
| Product | Affected versions | Fixed versions |
|---|---|---|
| cpe:2.3:a:apache:airflow:*:*:*:*:*:*:*:* | Not reported | Not reported |
| Package | Affected range | Fixed version |
|---|---|---|
| Apache Software Foundation/apache-airflowgeneric | >=0 <3.0.0 | 3.0.0 |
| Apache Software Foundation/apache-airflow-coregeneric | >=3.0.0 <3.2.0 | 3.2.0 |
| apache-airflow-corepip | <3.2.0 | 3.2.0 |
Published upstream
Apr 18, 2026
Evidence: source:cvelist:source_dates:source-dates:recordSource modified
Nov 3, 2026
Evidence: source:cvelist:source_dates:source-dates:recordFirst seen by HOL
Jun 11, 2026
In case of SQL errors, exception/stack trace of errors was exposed in API even if "api/expose_stack_traces" was set to false. That could lead to exposing additional information to potential attacker. Users are recommended to upgrade to Apache Airflow 3.2.0, which fixes the issue.
Quoted source text, attributed separately from HOL analysis.