Answer in brief
CVE-2026-39304 records a High severity (CVSS 7.5) vulnerability in Apache ActiveMQ Client, Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Incorrect handling of TLSv1.3 KeyUpdate can be exploited to cause DoS via OOM. The current sources do not mark it as known exploited. The current feed maps Red Hat/activemq-all (generic), Red Hat/activemq-broker (generic), Red Hat/activemq-client (generic), Apache Software Foundation/Apache ActiveMQ (generic) and additional mapped packages. Check affected ranges and fixed versions before updating.
Analysis pending evidence review
HOL Guard separates source facts from reviewed analysis. See the methodology.
CVSS is 7.5. The current sources do not mark it as known exploited. Treat this as a source-backed prioritization signal, not a statement about your environment.
Analysis status
Analysis pending evidence review
Factual feed record only; HOL analysis is not approved for indexing. Read the methodology.
The current feed maps Red Hat/activemq-all (generic), Red Hat/activemq-broker (generic), Red Hat/activemq-client (generic), Apache Software Foundation/Apache ActiveMQ (generic) and additional mapped packages. Check affected ranges and fixed versions before updating.
| Product | Affected versions | Fixed versions |
|---|---|---|
| cpe:2.3:a:apache:activemq:*:*:*:*:*:*:*:* | Not reported | Not reported |
| cpe:2.3:a:apache:activemq_broker:*:*:*:*:*:*:*:* | Not reported | Not reported |
| Package | Affected range | Fixed version |
|---|---|---|
| Red Hat/activemq-allgeneric | * | Not reported |
| Red Hat/activemq-brokergeneric | * | Not reported |
| Red Hat/activemq-clientgeneric | * | Not reported |
| Apache Software Foundation/Apache ActiveMQgeneric | >=0 <5.19.4 || >=6.0.0 <6.2.4 | 5.19.4, 6.2.4 |
| Apache Software Foundation/Apache ActiveMQ Allgeneric | >=0 <5.19.4 || >=6.0.0 <6.2.4 | 5.19.4, 6.2.4 |
| Apache Software Foundation/Apache ActiveMQ Brokergeneric | >=0 <5.19.4 || >=6.0.0 <6.2.4 | 5.19.4, 6.2.4 |
| Apache Software Foundation/Apache ActiveMQ Clientgeneric | >=0 <5.19.4 || >=6.0.0 <6.2.4 | 5.19.4, 6.2.4 |
| Apache Software Foundation/org.apache.activemq:activemq-allgeneric | >=0 <5.19.4 || >=6.0.0 <6.2.4 | 5.19.4, 6.2.4 |
| Apache Software Foundation/org.apache.activemq:activemq-brokergeneric | >=0 <5.19.4 || >=6.0.0 <6.2.4 | 5.19.4, 6.2.4 |
| Apache Software Foundation/org.apache.activemq:activemq-clientgeneric | >=0 <5.19.4 || >=6.0.0 <6.2.4 | 5.19.4, 6.2.4 |
| Apache Software Foundation/org.apache.activemq:apache-activemqgeneric | >=0 <5.19.4 || >=6.0.0 <6.2.4 | 5.19.4, 6.2.4 |
Published upstream
Apr 10, 2026
Evidence: source:cvelist:source_dates:source-dates:recordSource modified
Oct 26, 2026
Evidence: source:cvelist:source_dates:source-dates:recordFirst seen by HOL
Jul 15, 2026
Denial of Service via Out of Memory vulnerability in Apache ActiveMQ Client, Apache ActiveMQ Broker, Apache ActiveMQ. ActiveMQ NIO SSL transports do not correctly handle TLSv1.3 handshake KeyUpdates triggered by clients. This makes it possible for a client to rapidly trigger updates which causes the broker to exhaust all its memory in the SSL engine leading to DoS. Note: TLS versions before TLSv1.3 (such as TLSv1.2) are broken but are not vulnerable to OOM. Previous TLS versions require a full handshake renegotiation which causes a connection to hang but not OOM. This is fixed as well. This issue affects Apache ActiveMQ Client: before 5.19.4, from 6.0.0 before 6.2.4; Apache ActiveMQ Broker: before 5.19.4, from 6.0.0 before 6.2.4; Apache ActiveMQ: before 5.19.4, from 6.0.0 before 6.2.4. Users are recommended to upgrade to version 6.2.4 or 5.19.5, which fixes the issue.
Quoted source text, attributed separately from HOL analysis.