Answer in brief
CVE-2026-48717 records a Medium severity (CVSS 9.1) vulnerability in OpenAM OAuth Authorization Bypass via PKCE Challenge. The current sources do not mark it as known exploited. The current feed maps OpenIdentityPlatform/OpenAM (generic), org.openidentityplatform.openam:openam-oauth2 (maven), org.openidentityplatform.openam:openam-oauth2 (maven). Check affected ranges and fixed versions before updating.
Analysis pending evidence review
HOL Guard separates source facts from reviewed analysis. See the methodology.
CVSS is 9.1. The current sources do not mark it as known exploited. Treat this as a source-backed prioritization signal, not a statement about your environment.
Analysis status
Analysis pending evidence review
Factual feed record only; HOL analysis is not approved for indexing. Read the methodology.
The current feed maps OpenIdentityPlatform/OpenAM (generic), org.openidentityplatform.openam:openam-oauth2 (maven), org.openidentityplatform.openam:openam-oauth2 (maven). Check affected ranges and fixed versions before updating.
| Package | Affected range | Fixed version |
|---|---|---|
| OpenIdentityPlatform/OpenAMgeneric | <16.1.1 | 16.1.1 |
| org.openidentityplatform.openam:openam-oauth2maven | <=16.0.6 | 16.1.1 |
| org.openidentityplatform.openam:openam-oauth2maven | >=0 <16.1.1 | 16.1.1 |
Published upstream
Sep 15, 2026
Evidence: source:cvelist:source_dates:source-dates:recordSource modified
Sep 23, 2026
Evidence: source:cvelist:source_dates:source-dates:recordFirst seen by HOL
Jun 29, 2026
Open Access Management (OpenAM) is an access management solution. Prior to 16.1.1, AuthorizationCodeGrantTypeHandler requires a code_verifier only when the realm-wide codeVerifierEnforced setting is enabled, even when an authorization code stores a code_challenge. Because that setting is disabled by default, an attacker who intercepts a PKCE-protected authorization code can omit code_verifier and redeem the code, while an explicitly incorrect verifier is rejected. Public clients are directly affected, and confidential-client exploitation additionally requires client authentication material or another redemption context. This issue is fixed in version 16.1.1.
Quoted source text, attributed separately from HOL analysis.