Answer in brief
CVE-2026-49877 records a High severity (CVSS 8.1) vulnerability in Apache ActiveMQ Improper Authorization vulnerability. The current sources do not mark it as known exploited. The current feed maps org.apache.activemq:apache-activemq (maven), org.apache.activemq:apache-activemq (maven). Check affected ranges and fixed versions before updating.
Analysis pending evidence review
HOL Guard separates source facts from reviewed analysis. See the methodology.
CVSS is 8.1. The current sources do not mark it as known exploited. Treat this as a source-backed prioritization signal, not a statement about your environment.
Analysis status
Analysis pending evidence review
Factual feed record only; HOL analysis is not approved for indexing. Read the methodology.
The current feed maps org.apache.activemq:apache-activemq (maven), org.apache.activemq:apache-activemq (maven). Check affected ranges and fixed versions before updating.
| Product | Affected versions | Fixed versions |
|---|---|---|
| cpe:2.3:a:apache:activemq:*:*:*:*:*:*:*:* | Not reported | Not reported |
| Package | Affected range | Fixed version |
|---|---|---|
| org.apache.activemq:apache-activemqmaven | >=6.0.0,<6.2.7 | 6.2.7 |
| org.apache.activemq:apache-activemqmaven | <5.19.8 | 5.19.8 |
Published upstream
Jun 30, 2026
Evidence: source:ghsa:source_dates:source-dates:recordSource modified
Nov 4, 2026
Evidence: source:ghsa:source_dates:source-dates:recordFirst seen by HOL
Jun 30, 2026
Improper Authorization vulnerability in Apache ActiveMQ. An authenticated low-privilege Web Console user by default can access /admin/* paths in the Web Console. The default Jetty settings incorrectly did not limit those paths to only admins. This issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7. Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.
Quoted source text, attributed separately from HOL analysis.