Answer in brief
CVE-2026-56091 records a High severity (CVSS 8.2) vulnerability in Apache Shiro shiro-guice module vulnerable to authentication bypass. The current sources do not mark it as known exploited. The current feed maps org.apache.shiro:shiro-guice (maven), org.apache.shiro:shiro-guice (maven). Check affected ranges and fixed versions before updating.
Analysis pending evidence review
HOL Guard separates source facts from reviewed analysis. See the methodology.
CVSS is 8.2. The current sources do not mark it as known exploited. Treat this as a source-backed prioritization signal, not a statement about your environment.
Analysis status
Analysis pending evidence review
Factual feed record only; HOL analysis is not approved for indexing. Read the methodology.
The current feed maps org.apache.shiro:shiro-guice (maven), org.apache.shiro:shiro-guice (maven). Check affected ranges and fixed versions before updating.
| Package | Affected range | Fixed version |
|---|---|---|
| org.apache.shiro:shiro-guicemaven | >=2.0.0,<3.0.0 | 3.0.0 |
| org.apache.shiro:shiro-guicemaven | >=2.0.0 <3.0.0 | 3.0.0 |
Published upstream
Jun 25, 2026
Evidence: source:ghsa:source_dates:source-dates:recordSource modified
Nov 3, 2026
Evidence: source:ghsa:source_dates:source-dates:recordFirst seen by HOL
Jun 25, 2026
When using Apache Shiro with the shiro-guice module in a web servlet context, a specially crafted HTTP request may cause an authentication bypass. This vulnerability is similar to https://www.cve.org/CVERecord?id=CVE-2020-1957 https://www.cve.org/CVERecord , except that it affects the `shiro-guice` module instead of the `shiro-spring` module. This issue affects all Apache Shiro versions through 2.x, and 3.0.0-alpha-1 only when using `shiro-guice` module in a web servlet context. Upgrade to version 3.0.0 or later, which fixes the issue.
Quoted source text, attributed separately from HOL analysis.