Answer in brief
CVE-2026-57217 records a High severity (CVSS 7.0) vulnerability in RabbitMQ: Topic authorization can lead to cross-tenant routing-key bypass. The current sources do not mark it as known exploited. The current feed maps rabbitmq/rabbitmq-server (generic). Check affected ranges and fixed versions before updating.
Analysis pending evidence review
HOL Guard separates source facts from reviewed analysis. See the methodology.
CVSS is 7.0. The current sources do not mark it as known exploited. Treat this as a source-backed prioritization signal, not a statement about your environment.
Analysis status
Analysis pending evidence review
Factual feed record only; HOL analysis is not approved for indexing. Read the methodology.
The current feed maps rabbitmq/rabbitmq-server (generic). Check affected ranges and fixed versions before updating.
| Product | Affected versions | Fixed versions |
|---|---|---|
| cpe:2.3:a:broadcom:rabbitmq_server:*:*:*:*:*:*:*:* | Not reported | Not reported |
| Package | Affected range | Fixed version |
|---|---|---|
| rabbitmq/rabbitmq-servergeneric | >=4.2.0 <4.2.6 || >=4.1.0 <4.1.11 || >=4.0.0 <4.0.21 || >=3.13.0 <3.13.15 | 4.2.6, 4.1.11, 4.0.21, 3.13.15 |
Published upstream
Jul 10, 2026
Evidence: source:cvelist:source_dates:source-dates:recordSource modified
Oct 25, 2026
Evidence: source:cvelist:source_dates:source-dates:recordFirst seen by HOL
Jul 10, 2026
RabbitMQ is a messaging and streaming broker. Prior to 3.13.15, 4.0.21, 4.1.11, and 4.2.6, RabbitMQ topic authorization can allow restricted topic writes and binds during metadata-store failures because topic-permission lookup errors from Khepri can collapse to undefined, which the internal backend treats as allow. This issue is fixed in versions 3.13.15, 4.0.21, 4.1.11, and 4.2.6.
Quoted source text, attributed separately from HOL analysis.