Answer in brief
CVE-2026-76646 records a High severity (CVSS 7.5) vulnerability in Apache MyFaces: Denial of Service via Unbounded Request Parsing. The current sources do not mark it as known exploited. The current feed maps Apache Software Foundation/Apache MyFaces (generic), Apache Software Foundation/Apache MyFaces (generic). Check affected ranges and fixed versions before updating.
Analysis pending evidence review
HOL Guard separates source facts from reviewed analysis. See the methodology.
CVSS is 7.5. The current sources do not mark it as known exploited. Treat this as a source-backed prioritization signal, not a statement about your environment.
Analysis status
Analysis pending evidence review
Factual feed record only; HOL analysis is not approved for indexing. Read the methodology.
The current feed maps Apache Software Foundation/Apache MyFaces (generic), Apache Software Foundation/Apache MyFaces (generic). Check affected ranges and fixed versions before updating.
| Package | Affected range | Fixed version |
|---|---|---|
| Apache Software Foundation/Apache MyFacesgeneric | 2.2.0-beta || 2.3.0 || 2.3-next-M1 || 2.3.1 || 3.0.0 || 4.0.0 || 4.1.0 | Not reported |
| Apache Software Foundation/Apache MyFacesgeneric | >=2.2.0-beta <=2.2.15 || 2.3.0 || >=2.3-next-M1 <=2.3-next-M8 || >=2.3.1 <=2.3.11 || >=3.0.0 <=3.0.3 || >=4.0.0 <=4.0.3 || >=4.1.0 <=4.1.3 | Not reported |
Published upstream
Sep 16, 2026
Evidence: source:cvelist:source_dates:source-dates:recordSource modified
Sep 17, 2026
Evidence: source:cvelist:source_dates:source-dates:recordFirst seen by HOL
Sep 16, 2026
A remote attacker could cause excessive resource consumption by supplying specially crafted request parameters, potentially resulting in a denial of service condition. Older unsupported versions may also be affected. Users are recommended to upgrade to versions 2.3.12, 2.3-next-M9, 3.0.4, 4.0.4, or 4.1.4, which fix this issue.
Quoted source text, attributed separately from HOL analysis.