Answer in brief
CVE-2026-77405 records a Critical severity (CVSS 0.0) vulnerability in RabbitMQ amqp091-go: Missing Explicit TLS Minimum Version Configuration In URI Parser. The current sources do not mark it as known exploited. The current feed maps rabbitmq/amqp091-go (generic), github.com/rabbitmq/amqp091-go (go), github.com/rabbitmq/amqp091-go (go). Check affected ranges and fixed versions before updating.
Analysis pending evidence review
HOL Guard separates source facts from reviewed analysis. See the methodology.
CVSS is 0.0. The current sources do not mark it as known exploited. Treat this as a source-backed prioritization signal, not a statement about your environment.
Analysis status
Analysis pending evidence review
Factual feed record only; HOL analysis is not approved for indexing. Read the methodology.
The current feed maps rabbitmq/amqp091-go (generic), github.com/rabbitmq/amqp091-go (go), github.com/rabbitmq/amqp091-go (go). Check affected ranges and fixed versions before updating.
| Package | Affected range | Fixed version |
|---|---|---|
| rabbitmq/amqp091-gogeneric | <1.13.0 | 1.13.0 |
| github.com/rabbitmq/amqp091-gogo | <1.13.0 | 1.13.0 |
| github.com/rabbitmq/amqp091-gogo | >=0 <1.13.0 | 1.13.0 |
Published upstream
Sep 16, 2026
Evidence: source:cvelist:source_dates:source-dates:recordSource modified
Oct 1, 2026
Evidence: source:cvelist:source_dates:source-dates:recordFirst seen by HOL
Sep 16, 2026
RabbitMQ amqp091-go is a Go AMQP 0.9.1 client. Prior to 1.13.0, tlsConfigFromURI in uri.go creates tls.Config values without setting MinVersion to tls.VersionTLS12. Builds using a Go runtime whose default permits TLS 1.0 or TLS 1.1 can therefore negotiate an obsolete protocol version when connecting through an amqps URI. A network attacker able to influence TLS negotiation with such a legacy build may weaken transport protection for AMQP messages and credentials. This issue is fixed in version 1.13.0.
Quoted source text, attributed separately from HOL analysis.