Answer in brief
CVE-2026-59965 records a High severity (CVSS 7.1) vulnerability in @jhb.software/payload-alt-text-plugin: Alt Text Endpoint Authorization Bypass via Payload Local API `overrideAccess` Omission. The current sources do not mark it as known exploited. The current feed maps @jhb.software/payload-alt-text-plugin (generic), jhb-software/payload-plugins (generic), @jhb.software/payload-alt-text-plugin (npm), @jhb.software/payload-alt-text-plugin (npm) and additional mapped packages. Check affected ranges and fixed versions before updating.
Analysis pending evidence review
HOL Guard separates source facts from reviewed analysis. See the methodology.
CVSS is 7.1. The current sources do not mark it as known exploited. Treat this as a source-backed prioritization signal, not a statement about your environment.
Analysis status
Analysis pending evidence review
Factual feed record only; HOL analysis is not approved for indexing. Read the methodology.
The current feed maps @jhb.software/payload-alt-text-plugin (generic), jhb-software/payload-plugins (generic), @jhb.software/payload-alt-text-plugin (npm), @jhb.software/payload-alt-text-plugin (npm) and additional mapped packages. Check affected ranges and fixed versions before updating.
| Package | Affected range | Fixed version |
|---|---|---|
| @jhb.software/payload-alt-text-plugingeneric | <0.8.0 | 0.8.0 |
| jhb-software/payload-pluginsgeneric | <0.8.0 | 0.8.0 |
| @jhb.software/payload-alt-text-pluginnpm | >=0 | Not reported |
| @jhb.software/payload-alt-text-pluginnpm | <0.8.0 | 0.8.0 |
| @jhb.software/payload-alt-text-pluginnpm | >=0 <0.8.0 | 0.8.0 |
| @jhb.software/payload-alt-text-pluginnpm | <=0.7.0 | Not reported |
Published upstream
Sep 15, 2026
Evidence: source:cvelist:source_dates:source-dates:recordSource modified
Sep 30, 2026
Evidence: source:cvelist:source_dates:source-dates:recordFirst seen by HOL
Sep 10, 2026
Payload Plugins is a collection of plugins designed to enhance Payload CMS. In 0.7.0, @jhb.software/payload-alt-text-plugin exposes POST /api/alt-text-plugin/generate and POST /api/alt-text-plugin/bulk with a default guard that accepts any authenticated user, while alt-text/src/endpoints/generateAltText.ts and alt-text/src/endpoints/bulkGenerateAltTexts.ts call req.payload.findByID and req.payload.update without overrideAccess: false. Payload therefore defaults overrideAccess to true and skips the target collection's read and update access functions. An authenticated low-privilege user can supply id, collection, locale, and update values to read arbitrary protected upload documents and overwrite their alt and keywords fields, even when the collection permits those operations only to administrators. A control Local API call with overrideAccess: false is denied, confirming that the plugin endpoint bypasses otherwise effective collection rules. This vulnerability is fixed in 0.8.0.
Quoted source text, attributed separately from HOL analysis.